[lms] wtyczka Adescom w ramach LMS+

Tomasz Chiliński tomasz.chilinski w chilan.com
Czw, 25 Paź 2018, 12:07:09 CEST


Witam,

w ramach projektu LMS+ została przygotowana gałąź 'adescom' zawierająca 
kod wtyczki
dostosowany do wydań stabilnych LMS+ 1.11.23.x.
Parę zmian poczynionych we wtyczce ułatwi utrzymywanie jej w zgodności z 
następnymi wydaniami LMS+
(trochę rzeczy z czasem zostanie jeszcze pewnie przepisanych we wtyczce 
na nowo, żeby zwiększyć
automatyczną zgodność z nowszymi LMS+).

Pierwotnie wtyczka działała z PHP 5.4 lub nowszym, ale nie było to 
merytorycznie uzasadnione, żeby z powodu paru wywołań obiektowych
nie pozwolić na uruchamianie na PHP 5.3 - w związku z tym zostało 
przystosowane. RHEL/CentOS 6 nadal używa fabrycznie PHP 5.3 (przenosi 
poprawki
bezpieczeństwa na utrzymywaną przez siebie linię 5.3). Ta dystrybucja ma 
wsparcie do 2020 roku, więc już niedługo będzie można pozbyć
się balastu PHP 5.3 (myślę, że nawet grubo przed 2020 rokiem - pewnie w 
przyszłym roku) i zalecić aktualizację do RHEL/CentOS 7
(tam jest PHP 5.4 - również utrzymywane we własnym zakresie przez firmę 
RedHat).

Bezpośredni URL do gałęzi 'adescom':
https://github.com/chilek/lms-plus/tree/adescom

-- 
Pozdrawiam
Tomasz Chiliński, Chilan
opiekun projektu LMS - http://lms.org.pl
kierownik projektu LMS Plus / LMS+ - http://lms-plus.org


Więcej informacji o liście lms